Palo Alto Networks PAN-OS 7.0.x < 7.0.8 Multiple Vulnerabilities (PAN-SA-2016-0008 / PAN-SA-2016-0009)

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

The remote host is affected by multiple vulnerabilities.

Description :

The version of Palo Alto Networks PAN-OS running on the remote host is
7.0.x prior to 7.0.8. It is, therefore, affected by the following
vulnerabilities :

- A denial of service vulnerability exists in the API
hosted on the management interface, specifically in the
panUserLogin() function within panmodule.so, due to
improper validation of user-supplied input to the
'username' and 'password' parameters. An
unauthenticated, remote attacker can exploit this, via a
crafted request, to cause the process to terminate.
(PAN-SA-2016-0008)

- A cross-site scripting (XSS) vulnerability exists in the
Application Command Center (ACC) due to improper
sanitization of user-supplied input before returning it
to users. An authenticated, remote attacker can exploit
this, via a specially crafted request, to execute
arbitrary script code in a user's browser session.
(PAN-SA-2016-0009, CVE-2016-2219)

See also :

https://securityadvisories.paloaltonetworks.com/Home/Detail/41
https://securityadvisories.paloaltonetworks.com/Home/Detail/42
http://www.tenable.com/security/research/tra-2016-19

Solution :

Upgrade to Palo Alto Networks PAN-OS version 7.0.8 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 4.1
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Palo Alto Local Security Checks

Nessus Plugin ID: 92942 ()

Bugtraq ID: 91461
91468

CVE ID: CVE-2016-2219

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now