This script is Copyright (C) 2016-2017 Tenable Network Security, Inc.
An application installed on the remote host is affected by multiple
According to its self-reported version, the Tenable SecurityCenter
application installed on the remote host is prior to 5.4.0. It is,
therefore, affected by multiple vulnerabilities :
- An arbitrary code execution vulnerability exists in the
bundled version of libcurl due to using an insecure path
to look for specific libraries, including the current
working directory, which may not be under user control.
A remote attacker can exploit this to inject and execute
arbitrary code in the context of the current user.
- Multiple flaws exist in the bundled version of libssh
due to a failure to securely generate Diffie-Hellman
secret keys. A man-in-the-middle attacker can exploit
these flaws to intercept and decrypt SSH sessions.
- An integer overflow condition exists in the bundled
version of libcurl due to improper validation of
user-supplied input when handling 'timeval'. An attacker
can exploit this to have an unspecified impact.
Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.
See also :
Upgrade to Tenable SecurityCenter version 5.4.0 or later.
Risk factor :
High / CVSS Base Score : 7.1
CVSS Temporal Score : 5.3
Public Exploit Available : false