GLSA-201606-10 : PHP: Multiple vulnerabilities

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-201606-10
(PHP: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in PHP. Please review the
CVE identifiers referenced below for details.

Impact :

An attacker can possibly execute arbitrary code or create a Denial of
Service condition.

Workaround :

There is no known workaround at this time.

See also :

https://security.gentoo.org/glsa/201606-10

Solution :

All PHP 5.4 users should upgrade to the latest 5.5 stable branch, as PHP
5.4 is now masked in Portage:
# emerge --sync
# emerge --ask --oneshot --verbose '>=dev=lang/php-5.5.33'
All PHP 5.5 users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=dev=lang/php-5.5.33'
All PHP 5.6 users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=dev=lang/php-5.6.19'

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)