openSUSE Security Update : libtasn1 (openSUSE-2016-716)

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update for libtasn1 fixes the following issues :

- Malformed asn1 definitions could have caused a
segmentation fault in the asn1 definition parser
(bsc#961491)

- CVE-2015-3622: Fixed invalid read in octet string
decoding (bsc#929414)

- CVE-2016-4008: Fixed infinite loop while parsing DER
certificates (bsc#982779)

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=929414
https://bugzilla.opensuse.org/show_bug.cgi?id=961491
https://bugzilla.opensuse.org/show_bug.cgi?id=982779

Solution :

Update the affected libtasn1 packages.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 91619 ()

Bugtraq ID:

CVE ID: CVE-2015-3622
CVE-2016-4008

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now