openSUSE Security Update : libressl (openSUSE-2016-604)

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This libressl update to version 2.2.7 fixes the following issues :

Security issues fixed :

- Fix multiple vulnerabilities in libcrypto relating to
ASN.1 and encoding. [boo#978492, boo#977584]

- CVE-2015-3194: Certificate verify crash with missing PSS
parameter (boo#957815)

- CVE-2015-3195: X509_ATTRIBUTE memory leak (boo#957812)

- CVE-2015-5333: Memory Leak (boo#950707)

- CVE-2015-5334: Buffer Overflow (boo#950708)

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=950707
https://bugzilla.opensuse.org/show_bug.cgi?id=950708
https://bugzilla.opensuse.org/show_bug.cgi?id=957812
https://bugzilla.opensuse.org/show_bug.cgi?id=957815
https://bugzilla.opensuse.org/show_bug.cgi?id=977584
https://bugzilla.opensuse.org/show_bug.cgi?id=978492

Solution :

Update the affected libressl packages.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 91274 ()

Bugtraq ID:

CVE ID: CVE-2015-3194
CVE-2015-3195
CVE-2015-5333
CVE-2015-5334

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now