openSUSE Security Update : compat-openssl098 (openSUSE-2016-575)

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update for compat-openssl098 fixes the following issues :

- CVE-2016-2108: Memory corruption in the ASN.1 encoder
(bsc#977617)

- CVE-2016-2105: EVP_EncodeUpdate overflow (bsc#977614)

- CVE-2016-2106: EVP_EncryptUpdate overflow (bsc#977615)

- CVE-2016-2109: ASN.1 BIO excessive memory allocation
(bsc#976942)

- CVE-2016-0702: Side channel attack on modular
exponentiation 'CacheBleed' (bsc#968050)

- bsc#976943: Buffer overrun in ASN1_parse

The following non-security bugs were fixed :

- bsc#889013: Rename README.SuSE to the new spelling
(bsc#889013)

This update was imported from the SUSE:SLE-12:Update update project.

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=889013
https://bugzilla.opensuse.org/show_bug.cgi?id=968050
https://bugzilla.opensuse.org/show_bug.cgi?id=976942
https://bugzilla.opensuse.org/show_bug.cgi?id=976943
https://bugzilla.opensuse.org/show_bug.cgi?id=977614
https://bugzilla.opensuse.org/show_bug.cgi?id=977615
https://bugzilla.opensuse.org/show_bug.cgi?id=977617

Solution :

Update the affected compat-openssl098 packages.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)

Family: SuSE Local Security Checks

Nessus Plugin ID: 91070 ()

Bugtraq ID:

CVE ID: CVE-2016-0702
CVE-2016-2105
CVE-2016-2106
CVE-2016-2108
CVE-2016-2109

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now