OpenSSL 1.0.2 < 1.0.2c ASN.1 Encoder Negative Zero Value Handling RCE

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

The remote service is affected by a remote code execution
vulnerability.

Description :

According to its banner, the remote host is running a version of
OpenSSL 1.0.2 prior to 1.0.2c. It is, therefore, affected by a remote
code execution vulnerability in the ASN.1 encoder due to an underflow
condition that occurs when attempting to encode the value zero
represented as a negative integer. An unauthenticated, remote attacker
can exploit this to corrupt memory, resulting in the execution of
arbitrary code.

See also :

https://www.openssl.org/news/secadv/20160503.txt
https://www.openssl.org/news/cl102.txt

Solution :

Upgrade to OpenSSL version 1.0.2c or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.4
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 90889 ()

Bugtraq ID: 89752

CVE ID: CVE-2016-2108

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now