FreeBSD : gitlab -- privilege escalation via 'impersonate' feature (be72e773-1131-11e6-94fa-002590263bf5)

This script is Copyright (C) 2016-2017 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing one or more security-related
updates.

Description :

GitLab reports :

During an internal code review, we discovered a critical security flaw
in the 'impersonate' feature of GitLab. Added in GitLab 8.2, this
feature was intended to allow an administrator to simulate being
logged in as any other user.

A part of this feature was not properly secured and it was possible
for any authenticated user, administrator or not, to 'log in' as any
other user, including administrators. Please see the issue for more
details.

See also :

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=209225
https://about.gitlab.com/2016/05/02/cve-2016-4340-patches/
https://gitlab.com/gitlab-org/gitlab-ce/issues/15548
http://www.nessus.org/u?5d3a4046

Solution :

Update the affected packages.

Risk factor :

Medium / CVSS Base Score : 6.5
(CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P)

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 90877 ()

Bugtraq ID:

CVE ID: CVE-2016-4340

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now