Adobe Flash Player for Mac <= 21.0.0.197 Multiple Vulnerabilities (APSB16-10)

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host has a browser plugin installed that is
affected by multiple vulnerabilities.

Description :

The version of Adobe Flash Player installed on the remote Mac OS X
host is prior or equal to version 21.0.0.197. It is, therefore,
affected by multiple vulnerabilities :

- An Address Space Layout Randomization (ASLR) bypass
vulnerability exists that allows an attacker to predict
memory offsets in the call stack. (CVE-2016-1006)

- Multiple use-after-free errors exist that allow an
attacker to execute arbitrary code. (CVE-2016-1011,
CVE-2016-1013, CVE-2016-1016, CVE-2016-1017,
CVE-2016-1031)

- Multiple memory corruption issues exist that allow an
attacker to execute arbitrary code. (CVE-2016-1012,
CVE-2016-1020, CVE-2016-1021, CVE-2016-1022,
CVE-2016-1023, CVE-2016-1024, CVE-2016-1025,
CVE-2016-1026, CVE-2016-1027, CVE-2016-1028,
CVE-2016-1029, CVE-2016-1032, CVE-2016-1033)

- A directory search path vulnerability exists that allows
an attacker to disclose sensitive resources.
(CVE-2016-1014)

- Multiple type confusion errors exist that allow an
attacker to execute arbitrary code. (CVE-2016-1015,
CVE-2016-1019)

- An overflow condition exists that is triggered when
handling JPEG-XR compressed image content. An attacker
can exploit this to execute arbitrary code.
(CVE-2016-1018)

- An unspecified security bypass vulnerability exists.
(CVE-2016-1030)

See also :

https://helpx.adobe.com/security/products/flash-player/apsb16-10.html
http://www.nessus.org/u?0cb17c10

Solution :

Upgrade to Adobe Flash Player version 21.0.0.213 or later.

Alternatively, Adobe has made version 18.0.0.343 available for those
installations that cannot be upgraded to the latest version.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.8
(CVSS2#E:F/RL:U/RC:ND)
Public Exploit Available : true