NVIDIA Graphics Driver 340.x < 341.95 / 352.x < 354.74 Multiple Vulnerabilities

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

The remote Windows host is affected by multiple vulnerabilities.

Description :

The version of the NVIDIA graphics driver installed on the remote
Windows host is 340.x prior to 341.95 or 352.x prior to 354.74. It
is, therefore, affected by multiple vulnerabilities :

- A privilege escalation vulnerability exists due to a
kernel driver escape. A local attacker can exploit this
to gain unauthorized access to restricted functionality,
potentially allowing the execution of arbitrary code.
(CVE-2016-2556)

- An information disclosure vulnerability exists due to an
out-of-bounds read error. A local attacker can exploit
this to read arbitrary information from memory.
(CVE-2016-2557)

- An unspecified untrusted pointer flaw exists that allows
a local attacker to cause a denial of service condition
or the execution of arbitrary code. (CVE-2016-2558)

See also :

https://nvidia.custhelp.com/app/answers/detail/a_id/4059
https://nvidia.custhelp.com/app/answers/detail/a_id/4060
https://nvidia.custhelp.com/app/answers/detail/a_id/4061
http://www.nessus.org/u?6cb06842
http://www.nessus.org/u?88e2ba18
http://www.get-top-news.com/news-11914735.html

Solution :

Upgrade to video driver version 341.95 / 354.74 or later.

Risk factor :

High / CVSS Base Score : 7.2
(CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 5.3
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 90119 ()

Bugtraq ID:

CVE ID: CVE-2016-2556
CVE-2016-2557
CVE-2016-2558

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now