Samba 3.2.x < 4.1.23 / 4.2.x < 4.2.9 / 4.3.x < 4.3.6 / 4.4.0 < 4.4.0rc4 Multiple Vulnerabilities

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

The remote Samba server is affected by multiple vulnerabilities.

Description :

According to its banner, the version of Samba running on the remote
host is 3.2.x prior to 4.1.23, 4.2.x prior to 4.2.9, 4.3.x prior to
4.3.6, or 4.4.0 prior to 4.4.0rc4. It is, therefore, affected by the
following vulnerabilities :

- A security bypass vulnerability exists in the SMB1
implementation that is triggered when a symlink created
to a file or directory using SMB1 UNIX extensions is
accessed using non-UNIX SMB1 calls. An authenticated,
remote attacker can exploit this to overwrite file and
directory ACLs. (CVE-2015-7560)

- An out-of-bounds read error exists in the internal DNS
server due to improper handling of TXT records when an
AD DC is configured. An authenticated, remote attacker
can exploit this, via a crafted DNS TXT record, to cause
a crash or disclose memory contents. (CVE-2016-0771)

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

https://www.samba.org/samba/security/CVE-2015-7560.html
https://www.samba.org/samba/security/CVE-2016-0771.html
http://www.samba.org/samba/history/samba-4.1.23.html
http://www.samba.org/samba/history/samba-4.2.9.html
http://www.samba.org/samba/history/samba-4.3.6.html

Solution :

Upgrade to Samba version 4.1.23 / 4.2.9 / 4.3.6 / 4.4.0rc4 or later.

Risk factor :

Medium / CVSS Base Score : 4.9
(CVSS2#AV:N/AC:M/Au:S/C:P/I:N/A:P)
CVSS Temporal Score : 3.6
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 90098 ()

Bugtraq ID:

CVE ID: CVE-2015-7560
CVE-2016-0771

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now