Wireshark 2.0.x < 2.0.2 Multiple Vulnerabilities

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

The remote Windows host has an application installed that is affected
by multiple vulnerabilities.

Description :

The version of Wireshark installed on the remote Windows host is
2.0.x prior to 2.0.2. It is, therefore, affected by multiple
vulnerabilities in the following components, which can result in a
memory disclosure, a denial of service, or the execution of arbitrary
code :

- 3GPP TS 32.423 Trace file parser
- ASN.1 BER dissector
- DNP dissector
- GSM A-bis OML dissector
- HiQnet dissector
- HTTP/2 dissector
- IEEE 802.11 dissector
- iSeries file parser
- Ixia IxVeriWave file parser
- LBMC dissector
- LLRP dissector
- NFS dissector
- RSL dissector
- SPICE dissector
- X.509AF dissector

Additionally, a flaw related to how dynamic-link library (DLL) files
are located and loaded exists in the ui/qt/wireshark_application.cpp
file due to the application using a DLL search path that may include
directories that are not trusted or under the user's control. A local
attacker can exploit this issue, via a crafted DLL file injected into
the search path, to execute arbitrary code with the privileges of the
user running the application.

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

https://www.wireshark.org/docs/relnotes/wireshark-2.0.2.html

Solution :

Upgrade to Wireshark version 2.0.2 or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.8
(CVSS2#E:POC/RL:OF/RC:ND)
Public Exploit Available : true