Squid 3.5.13 / 4.0.4 / 4.0.5 Server Connection Error Handling DoS

This script is Copyright (C) 2016 Tenable Network Security, Inc.

Synopsis :

The remote proxy server is potentially affected by a denial of
service vulnerability.

Description :

According to its banner, the version of Squid running on the remote
host is 3.5.13, 4.0.4, or 4.0.5. It is, therefore, potentially
affected by a denial of service vulnerability due to improper handling
of server connection errors in the FwdState::connectedToPeer()
function. A remote attacker can exploit this, via a misconfigured
client or server, to cause a denial of service condition when
connecting to TLS or SSL servers.

Note that only servers built with the --with-openssl option are

Note that Nessus has not tested for this issue but has instead relied
only on the application's self-reported version number. The patch
released to address this issue does not update the version given in
the banner. If the patch has been applied properly, and the service
has been restarted, consider this to be a false positive.

See also :


Solution :

Upgrade to Squid version 3.5.14 / 4.0.6 or later. Alternatively, apply
the vendor-supplied patch.

Risk factor :

High / CVSS Base Score : 7.1
CVSS Temporal Score : 5.9
Public Exploit Available : true

Family: Firewalls

Nessus Plugin ID: 89052 ()

Bugtraq ID: 83261

CVE ID: CVE-2016-2390

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now