VMware ESX / ESXi Multiple Vulnerabilities (VMSA-2012-0009) (remote check)

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

The remote VMware ESX / ESXi host is missing a security-related patch.

Description :

The remote VMware ESX / ESXi host is affected by multiple
vulnerabilities :

- Multiple privilege escalation vulnerabilities exist due
to improper handling of RPC commands. A local attacker
(guest user) can exploit these to manipulate data and
function pointers, resulting in a denial of service
condition or the execution of arbitrary code on the host
OS. (CVE-2012-1516, CVE-2012-1517)

- A remote code execution vulnerability exists due to
improper sanitization of user-supplied input when
parsing NFS traffic. An unauthenticated, remote attacker
can exploit this to corrupt memory, resulting in the
execution of arbitrary code. (CVE-2012-2448)

- Multiple privilege escalation vulnerabilities exist due
to an error that occurs in virtual floppy devices and
SCSI devices. A local attacker (guest user) can exploit
these to cause an out-of-bounds write error, resulting
in a denial of service condition or the execution of
arbitrary code on the host OS. (CVE-2012-2449,
CVE-2012-2450)

See also :

http://www.vmware.com/security/advisories/VMSA-2012-0009.html

Solution :

Apply the appropriate patch according to the vendor advisory that
pertains to ESX version 3.5 / 4.0 / 4.1 or ESXi version 3.5 / 4.0 /
4.1 / 5.0.

Risk factor :

High / CVSS Base Score : 9.0
(CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C)
CVSS Temporal Score : 6.7
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 89035 ()

Bugtraq ID: 53369
53371

CVE ID: CVE-2012-1516
CVE-2012-1517
CVE-2012-2448
CVE-2012-2449
CVE-2012-2450

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now