Nessus Client 4.x < 4.2.0 QtWeb Path Subversion DLL Injection Local Code Execution

This script is Copyright (C) 2016-2017 Tenable Network Security, Inc.


Synopsis :

The remote Nessus Client is affected by a local code execution
vulnerability.

Description :

According to its version, the installation of Tenable Nessus Client
on the remote Windows host is version 4.x prior to 4.2.0. It is,
therefore, affected by a local code execution vulnerability in the
bundled version of QtWeb. QtWeb loads dynamic-link libraries using a
fixed path to look for specific files or libraries. A local attacker
can exploit this by placing a custom DLL file in the path, resulting
in the execution of arbitrary code.

See also :

https://www.tenable.com/security/tns-2010-03
http://seclists.org/fulldisclosure/2010/Aug/386
http://seclists.org/bugtraq/2010/Oct/231

Solution :

Upgrade to the current release of Nessus and uninstall the Nessus
Client.

Risk factor :

Medium / CVSS Base Score : 6.9
(CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C)

Family: Windows

Nessus Plugin ID: 89028 ()

Bugtraq ID: 42828

CVE ID: CVE-2010-5247

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now