Adobe Photoshop CC < 15.2.4 / 16.1.2 Multiple Memory Corruption Vulnerabilities (APSB16-03) (Mac OS X)

This script is Copyright (C) 2016-2017 Tenable Network Security, Inc.


Synopsis :

The remote host has an application installed that is affected by
multiple memory corruption vulnerabilities.

Description :

The version of Adobe Photoshop installed on the remote Mac OS X host
is prior to 15.2.4 (2014.2.4) or 16.1.2 (2015.1.2). It is, therefore,
affected by multiple unspecified memory corruption issues due to
improper validation of user-supplied input. An unauthenticated, remote
attacker can exploit these issues to execute arbitrary code.

See also :

https://helpx.adobe.com/security/products/photoshop/apsb16-03.html

Solution :

Upgrade to Adobe Photoshop CC version 15.2.4 (2014.2.4) / 16.1.2
(2015.1.2) or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:ND)
Public Exploit Available : true

Family: MacOS X Local Security Checks

Nessus Plugin ID: 88721 ()

Bugtraq ID: 83114

CVE ID: CVE-2016-0951
CVE-2016-0952
CVE-2016-0953

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now