FreeSWITCH < 1.4.26 / 1.6.x < 1.6.5 JSON Parser RCE

This script is Copyright (C) 2016-2017 Tenable Network Security, Inc.


Synopsis :

The remote FreeSWITCH server is affected by a remote code execution
vulnerability.

Description :

The remote FreeSWITCH server is prior to version 1.4.26 or 1.6.x prior
to 1.6.5. It is, therefore, affected by a remote code execution
vulnerability due to improper validation of user-supplied input to the
parse_string() function in esl_json.c, switch_json.c, and ks_json.c. A
remote attacker can exploit this, via a crafted JSON message, to cause
a heap-based buffer overflow condition, resulting in a denial of
service or the execution of arbitrary code.

See also :

https://freeswitch.org/jira/browse/FS-8160
https://www.tenable.com/security/research/tra-2015-05

Solution :

Upgrade to FreeSWITCH version 1.4.26 / 1.6.5 or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.5
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 88696 ()

Bugtraq ID: 76976

CVE ID: CVE-2015-7392
CVE-2015-8311

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now