SUSE SLED11 / SLES11 Security Update : ecryptfs-utils (SUSE-SU-2016:0290-1)

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

The remote SUSE host is missing one or more security updates.

Description :

This update for ecryptfs-utils fixes the following issues :

- CVE-2016-1572: A local user could have escalated
privileges by mounting over special filesystems
(bsc#962052)

- CVE-2014-9687: A default salt value reduced complexity
of offline precomputation attacks (bsc#920160)

Note that Tenable Network Security has extracted the preceding
description block directly from the SUSE security advisory. Tenable
has attempted to automatically clean and format it as much as possible
without introducing additional issues.

See also :

https://bugzilla.suse.com/920160
https://bugzilla.suse.com/962052
https://www.suse.com/security/cve/CVE-2014-9687.html
https://www.suse.com/security/cve/CVE-2016-1572.html
http://www.nessus.org/u?091ecbe5

Solution :

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product :

SUSE Linux Enterprise Server for VMWare 11-SP3 :

zypper in -t patch slessp3-ecryptfs-utils-12379=1

SUSE Linux Enterprise Server 11-SP4 :

zypper in -t patch slessp4-ecryptfs-utils-12379=1

SUSE Linux Enterprise Server 11-SP3 :

zypper in -t patch slessp3-ecryptfs-utils-12379=1

SUSE Linux Enterprise Desktop 11-SP4 :

zypper in -t patch sledsp4-ecryptfs-utils-12379=1

SUSE Linux Enterprise Desktop 11-SP3 :

zypper in -t patch sledsp3-ecryptfs-utils-12379=1

SUSE Linux Enterprise Debuginfo 11-SP4 :

zypper in -t patch dbgsp4-ecryptfs-utils-12379=1

SUSE Linux Enterprise Debuginfo 11-SP3 :

zypper in -t patch dbgsp3-ecryptfs-utils-12379=1

To bring your system up-to-date, use 'zypper patch'.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N)
CVSS Temporal Score : 4.2
(CVSS2#E:U/RL:U/RC:C)
Public Exploit Available : false

Family: SuSE Local Security Checks

Nessus Plugin ID: 88508 ()

Bugtraq ID: 72560

CVE ID: CVE-2014-9687
CVE-2016-1572

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now