Oracle VM VirtualBox < 4.0.36 / 4.1.44 / 4.2.36 / 4.3.34 / 5.0.10 Multiple Vulnerabilities (January 2016 CPU)

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

An application installed on the remote host is affected by multiple
vulnerabilities.

Description :

The Oracle VM VirtualBox application installed on the remote host is a
version prior to 4.0.36, 4.1.44, 4.2.36, 4.3.34, or 5.0.10. It is,
therefore, affected by the following vulnerabilities :

- A denial of service vulnerability exists due to an
infinite loop condition in the KVM subsystem of the Linux
kernel. A local attacker can exploit this, by triggering
many Alignment Check (#AC) exceptions, to cause an OS
panic or hang. (CVE-2015-5307)

- A integer overflow condition exists in the
PL_ARENA_ALLOCATE implementation in Netscape Portable
Runtime (NSPR) due to a failure to properly validate
user-supplied input during memory allocation. A remote
attacker can exploit this to corrupt memory, resulting
in a denial of service or execution of arbitrary code.
(CVE-2015-7183)

- A denial of service vulnerability exists due to an
infinite loop condition in the KVM subsystem of the Linux
kernel. A local attacker can exploit this, by triggering
many Debug (#DB) exceptions, to cause an OS panic or hang.
(CVE-2015-8104)

See also :

http://www.nessus.org/u?c48cc983
https://www.virtualbox.org/wiki/Changelog

Solution :

Upgrade to Oracle VM VirtualBox version 4.0.36 / 4.1.44 / 4.2.36 /
4.3.34 / 5.0.10 or later as referenced in the January 2016 Oracle
Critical Patch Update advisory.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.5
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 88051 ()

Bugtraq ID: 77415
77524
77528

CVE ID: CVE-2015-5307
CVE-2015-7183
CVE-2015-8104

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now