Mac OS X Libxslt Function Type Confusion RCE (Security Update 2016-001)

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

The remote host is missing a Mac OS X update that fixes a remote code
execution vulnerability.

Description :

The remote host is running a version of Mac OS X 10.9.5 or 10.10.5
that is missing Security Update 2016-001. It is, therefore, affected
by a remote code execution vulnerability due to a type confusion flaw
in the bundled libxslt component that is triggered when handling
invalid values. A remote attacker can exploit this, via a specially
crafted website, to cause a denial of service condition or the
execution of arbitrary code.

See also :

https://support.apple.com/en-us/HT205731
http://www.nessus.org/u?e3fa4477

Solution :

Install Security Update 2016-001 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.7
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: MacOS X Local Security Checks

Nessus Plugin ID: 88048 ()

Bugtraq ID: 77325

CVE ID: CVE-2015-7995

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now