VMware vCenter / vRealize Orchestrator Appliance 4.2.x / 5.x / 6.x Java Object Deserialization RCE (VMSA-2015-0009)

This script is Copyright (C) 2016-2017 Tenable Network Security, Inc.


Synopsis :

The remote host has a virtualization appliance installed that is
affected by a remote code execution vulnerability.

Description :

The version of VMware vCenter / vRealize Orchestrator Appliance
installed on the remote host is 4.2.x or 5.x or 6.x and includes the
Apache Commons Collections (ACC) library version 3.2.1. It is,
therefore, affected by a remote code execution vulnerability due to
unsafe deserialize calls of unauthenticated Java objects to the ACC
library. An unauthenticated, remote attacker can exploit this, by
sending a crafted request, to execute arbitrary code on the target
host.

See also :

https://www.vmware.com/security/advisories/VMSA-2015-0009
https://kb.vmware.com/selfservice/microsites/search.do?cmd=displayKC&externalId=2141244
http://www.nessus.org/u?91868e8b
http://www.nessus.org/u?e0204f30
http://www.infoq.com/news/2015/11/commons-exploit

Solution :

Apply the patch referenced in VMware KB 2141244.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)

Family: Misc.

Nessus Plugin ID: 87762 ()

Bugtraq ID: 79648

CVE ID: CVE-2015-6934

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now