FreeBSD : qemu -- stack buffer overflow while parsing SCSI commands (a267cd6c-b0c4-11e5-8d13-bc5ff45d0f28)

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing one or more security-related
updates.

Description :

Prasad J Pandit, Red Hat Product Security Team, reports :

Qemu emulator built with the SCSI device emulation support is
vulnerable to a stack-based buffer overflow issue. It could occur while
parsing SCSI command descriptor block with an invalid operation code.

A privileged(CAP_SYS_RAWIO) user inside guest could use this flaw to
crash the Qemu instance resulting in DoS.

See also :

http://openwall.com/lists/oss-security/2015/07/23/6
http://www.nessus.org/u?266a2293
http://www.nessus.org/u?64f5aeeb
http://www.nessus.org/u?50f7354f

Solution :

Update the affected packages.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P)

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 87701 ()

Bugtraq ID:

CVE ID: CVE-2015-5158

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now