VMware ESX / ESXi vSphere Client RCE (VMSA-2014-0003)

This script is Copyright (C) 2015-2016 Tenable Network Security, Inc.


Synopsis :

The remote VMware ESX / ESXi host is missing a security-related patch.

Description :

The remote VMware ESX / ESXi host is affected by a remote code
execution vulnerability in the vSphere Client versions 4.0 / 4.1 due
to improper validation of updates to client files. An unauthenticated,
remote attacker can exploit this, via a malicious link, to download
and execute arbitrary code from an untrusted URI.

See also :

https://www.vmware.com/security/advisories/VMSA-2014-0003
http://lists.vmware.com/pipermail/security-announce/2014/000236.html

Solution :

Apply the appropriate patch according to the vendor advisory that
pertains to ESX version 4.0 / 4.1 and ESXi version 4.0 / 4.1.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 87675 ()

Bugtraq ID: 66772

CVE ID: CVE-2014-1209

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now