openSUSE Security Update : OpenSSL (openSUSE-2015-908)

This script is Copyright (C) 2015-2016 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

OpenSSL was updated to fix three security issues.

The following vulnerabilities were fixed :

- CVE-2015-3194: Certificate verify crash with missing PSS
parameter (bsc#957815)

- CVE-2015-3195: X509_ATTRIBUTE memory leak (bsc#957812)

- CVE-2015-3196: Race condition handling PSK identify hint
(bsc#957813)

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=957812
https://bugzilla.opensuse.org/show_bug.cgi?id=957813
https://bugzilla.opensuse.org/show_bug.cgi?id=957815

Solution :

Update the affected OpenSSL packages.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 87447 ()

Bugtraq ID:

CVE ID: CVE-2015-3194
CVE-2015-3195
CVE-2015-3196

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now