OpenSSL 1.0.1 < 1.0.1q Multiple DoS

This script is Copyright (C) 2015-2017 Tenable Network Security, Inc.


Synopsis :

The remote service is affected by multiple denial of service
vulnerabilities.

Description :

According to its banner, the remote host is running a version of
OpenSSL 1.0.1 prior to 1.0.1q. It is, therefore, affected by the
following vulnerabilities :

- A NULL pointer dereference flaw exists in file
rsa_ameth.c when handling ASN.1 signatures that use the
RSA PSS algorithm but are missing a mask generation
function parameter. A remote attacker can exploit this
to cause the signature verification routine to crash,
leading to a denial of service. (CVE-2015-3194)

- A flaw exists in the ASN1_TFLG_COMBINE implementation in
file tasn_dec.c related to handling malformed
X509_ATTRIBUTE structures. A remote attacker can exploit
this to cause a memory leak by triggering a decoding
failure in a PKCS#7 or CMS application, resulting in a
denial of service. (CVE-2015-3195)

See also :

https://www.openssl.org/news/secadv/20151203.txt

Solution :

Upgrade to OpenSSL version 1.0.1q or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 3.7
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 87221 ()

Bugtraq ID: 78623
78626

CVE ID: CVE-2015-3194
CVE-2015-3195

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now