OpenSSL 0.9.8 < 0.9.8zh X509_ATTRIBUTE Memory Leak DoS

This script is Copyright (C) 2015-2017 Tenable Network Security, Inc.


Synopsis :

The remote host is affected by a denial of service vulnerability.

Description :

According to its banner, the remote host is running a version of
OpenSSL 0.9.8 prior to 0.9.8zh. It is, therefore, affected by a flaw
in the ASN1_TFLG_COMBINE implementation in file tasn_dec.c related to
handling malformed X509_ATTRIBUTE structures. A remote attacker can
exploit this to cause a memory leak by triggering a decoding failure
in a PKCS#7 or CMS application, resulting in a denial of service.

See also :

https://www.openssl.org/news/secadv/20151203.txt

Solution :

Upgrade to OpenSSL version 0.9.8zh or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 3.7
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 87219 ()

Bugtraq ID: 78626

CVE ID: CVE-2015-3195

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now