FreeBSD : openssl -- multiple vulnerabilities (4c8d1d72-9b38-11e5-aece-d050996490d0)

This script is Copyright (C) 2015-2016 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing one or more security-related
updates.

Description :

OpenSSL project reports :

- BN_mod_exp may produce incorrect results on x86_64 (CVE-2015-3193)

- Certificate verify crash with missing PSS parameter (CVE-2015-3194)

- X509_ATTRIBUTE memory leak (CVE-2015-3195)

- Race condition handling PSK identify hint (CVE-2015-3196)

- Anon DH ServerKeyExchange with 0 p parameter (CVE-2015-1794)

See also :

https://www.openssl.org/news/secadv/20151203.txt
http://www.nessus.org/u?d18eaaef

Solution :

Update the affected packages.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 87213 ()

Bugtraq ID:

CVE ID: CVE-2015-1794
CVE-2015-3193
CVE-2015-3194
CVE-2015-3195
CVE-2015-3196

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now