SolarWinds DameWare Mini Remote Control < 12.0 Hotfix 1 DWRCC.exe RCE

This script is Copyright (C) 2015-2016 Tenable Network Security, Inc.


Synopsis :

The remote host is running a remote management application that is
affected by a remote code execution vulnerability.

Description :

The remote host is running a version of SolarWinds DameWare Mini
Remote Control prior to 12.0 Hotfix 1. It is, therefore, affected by
a remote code execution vulnerability due to a flaw in the DWRCC.exe
URI handler that is triggered when handling certain command line
arguments. An unauthenticated, remote attacker can exploit this by
convincing a user to follow a link containing a crafted command line
argument, resulting in a stack-based buffer overflow and the execution
of arbitrary code.

See also :

https://thwack.solarwinds.com/message/308973
http://www.zerodayinitiative.com/advisories/ZDI-15-555/

Solution :

Upgrade to SolarWinds DameWare Mini Remote Control v12.0 Hotfix 1 or
later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 86994 ()

Bugtraq ID: 77549

CVE ID: CVE-2015-8220

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now