LibreOffice < 4.4.6 / 5.x < 5.0.1 Document Bookmark Arbitrary Code Execution

This script is Copyright (C) 2015-2016 Tenable Network Security, Inc.


Synopsis :

The remote host has an application installed that is affected by an
arbitrary code execution vulnerability.

Description :

The version of LibreOffice installed on the remote Windows host is
prior to 4.4.6 or 5.x prior to 5.0.1. It is, therefore, affected by a
memory corruption issue in 'filter/ww8/ww8scan.cxx' due to improper
validation of user-supplied input when handling bookmark status
positions. A remote attacker can exploit this, via a specially crafted
document, to cause a denial of service condition or the execution of
arbitrary code.

Note that Nessus has not attempted to exploit this issue but has
instead relied only on the application's self-reported version number.

See also :

http://www.nessus.org/u?c8cc4e31
http://listarchives.documentfoundation.org/www/announce/msg00243.html

Solution :

Upgrade to LibreOffice version 4.4.6 (4.4.6.3) / 5.0.1 (5.0.1.2) or
later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:ND)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 86901 ()

Bugtraq ID:

CVE ID: CVE-2015-5214

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now