openSUSE Security Update : libsndfile (openSUSE-2015-742)

This script is Copyright (C) 2015 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

The libsndfile package was updated to fix three security issues :

- CVE-2015-7805: fix for heap overflow via specially
crafted AIFF header (bsc#953516)

- CVE-2015-8075: fix for out of bounds read access in
function psf_strlcpy_crlf (bsc#953519)

- CVE-2014-9756: fix a divide-by-zero issue that can lead
to an DoS (bsc#953521)

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=953516
https://bugzilla.opensuse.org/show_bug.cgi?id=953519
https://bugzilla.opensuse.org/show_bug.cgi?id=953521

Solution :

Update the affected libsndfile packages.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)

Family: SuSE Local Security Checks

Nessus Plugin ID: 86891 ()

Bugtraq ID:

CVE ID: CVE-2014-9756
CVE-2015-7805
CVE-2015-8075

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now