nginx 1.9.x < 1.9.6 HTTPv2 PRI Double-Free DoS

This script is Copyright (C) 2015-2016 Tenable Network Security, Inc.

Synopsis :

The remote web server is affected by a denial of service

Description :

According to the self-reported version in its response header, the
version of nginx hosted on the remote web server is 1.9.x prior to
1.9.6. It is, therefore, affected by a denial of service vulnerability
due to a double-free memory error in the HTTPv2 module that is
triggered when handling certain PRI packets. An unauthenticated,
remote attacker can exploit this, via a crafted RPI packet, to cause a
section of heap-based memory to be freed twice, which can result in
crashing the server.

See also :

Solution :

Upgrade to nginx version 1.9.6 or later.

Risk factor :

High / CVSS Base Score : 7.8
CVSS Temporal Score : 6.4
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 86884 ()

Bugtraq ID:


Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now