Adobe AIR <= 19.0.0.213 Multiple Vulnerabilities (APSB15-28)

This script is Copyright (C) 2015-2016 Tenable Network Security, Inc.


Synopsis :

The remote Windows host has a browser plugin installed that is
affected by multiple vulnerabilities.

Description :

The version of Adobe AIR installed on the remote Windows host is equal
or prior to version 19.0.0.241. It is, therefore, affected by multiple
vulnerabilities :

- A type confusion error exists that allows an attacker to
execute arbitrary code. (CVE-2015-7659)

- A security bypass vulnerability exists that allows an
attacker to write arbitrary data to the file system
under user permissions. (CVE-2015-7662)

- Multiple use-after-free vulnerabilities exist that allow
an attacker to execute arbitrary code. (CVE-2015-7651,
CVE-2015-7652, CVE-2015-7653, CVE-2015-7654,
CVE-2015-7655, CVE-2015-7656, CVE-2015-7657,
CVE-2015-7658, CVE-2015-7660, CVE-2015-7661,
CVE-2015-7663, CVE-2015-8042, CVE-2015-8043,
CVE-2015-8044, CVE-2015-8046)

See also :

https://helpx.adobe.com/security/products/flash-player/apsb15-28.html

Solution :

Upgrade to Adobe AIR version 19.0.0.241 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:ND)
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now