openSUSE Security Update : krb5 (openSUSE-2015-709)

This script is Copyright (C) 2015 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

krb5 was updated to fix three security issues.

These security issues were fixed :

- CVE-2015-2695: Applications which call
gss_inquire_context() on a partially-established SPNEGO
context could have caused the GSS-API library to read
from a pointer using the wrong type, generally causing a
process crash. (bsc#952188).

- CVE-2015-2696: Applications which call
gss_inquire_context() on a partially-established IAKERB
context could have caused the GSS-API library to read
from a pointer using the wrong type, generally causing a
process crash. (bsc#952189).

- CVE-2015-2697: Incorrect string handling in
build_principal_va can lead to DOS (bsc#952190).

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=952188
https://bugzilla.opensuse.org/show_bug.cgi?id=952189
https://bugzilla.opensuse.org/show_bug.cgi?id=952190

Solution :

Update the affected krb5 packages.

Risk factor :

High / CVSS Base Score : 7.1
(CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:C)

Family: SuSE Local Security Checks

Nessus Plugin ID: 86800 ()

Bugtraq ID:

CVE ID: CVE-2015-2695
CVE-2015-2696
CVE-2015-2697

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now