openSUSE Security Update : postgresql92 (openSUSE-2015-708)

This script is Copyright (C) 2015-2016 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

postgresql92 was updated to version 9.2.14 to fix one security issue.

This security issue was fixed :

- CVE-2015-5288: The crypt function in contrib/pgcrypto in
PostgreSQL before 9.0.23, 9.1.x before 9.1.19, 9.2.x
before 9.2.14, 9.3.x before 9.3.10, and 9.4.x before
9.4.5 allowed attackers to cause a denial of service
(server crash) or read arbitrary server memory via a
'too-short' salt (bsc#949669).

For the full release notes see:
http://www.postgresql.org/docs/current/static/release-9-2-14.html

See also :

http://www.postgresql.org/docs/current/static/release-9-2-14.html
https://bugzilla.opensuse.org/show_bug.cgi?id=949669

Solution :

Update the affected postgresql92 packages.

Risk factor :

Medium / CVSS Base Score : 6.4
(CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 86777 ()

Bugtraq ID:

CVE ID: CVE-2015-5288

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now