Apple iTunes < 12.2 Multiple Vulnerabilities (uncredentialed check)

This script is Copyright (C) 2015 Tenable Network Security, Inc.


Synopsis :

The remote host contains an application that is affected by multiple
vulnerabilities.

Description :

The version of Apple iTunes running on the remote host is prior to
12.2. It is, therefore, affected by multiple vulnerabilities due to
memory corruption issues in the WebKit component. An attacker can
exploit these to cause a denial of service or execute arbitrary code.

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

https://support.apple.com/kb/HT204949
http://www.nessus.org/u?fe3244d5

Solution :

Upgrade to Apple version iTunes 12.2 or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 9.5
(CVSS2#E:F/RL:ND/RC:ND)
Public Exploit Available : true