Oracle Linux 6 / 7 : docker-engine (ELSA-2015-3085)

This script is Copyright (C) 2015 Tenable Network Security, Inc.


Synopsis :

The remote Oracle Linux host is missing a security update.

Description :

Description of changes:

[1.8.3-1.0.1]
- Enable configuration of Docker daemon via sysconfig [orabug 21804877]
- Add documentation files to binary RPM

[1.8.3]
- Fix layer IDs lead to local graph poisoning (CVE-2014-8178)
- Fix manifest validation and parsing logic errors allow pull-by-digest
validation bypass (CVE-2014-8179)
- Add --disable-legacy-registry to prevent a daemon from using a v1 registry

See also :

https://oss.oracle.com/pipermail/el-errata/2015-October/005455.html
https://oss.oracle.com/pipermail/el-errata/2015-October/005456.html

Solution :

Update the affected docker-engine package.

Risk factor :

High

Family: Oracle Linux Local Security Checks

Nessus Plugin ID: 86395 ()

Bugtraq ID:

CVE ID: CVE-2014-8178
CVE-2014-8179

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now