FreeBSD : codeigniter -- multiple vulnerabilities (c21f4e61-6570-11e5-9909-002590263bf5)

This script is Copyright (C) 2015 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing a security-related update.

Description :

The CodeIgniter changelog reports :

Security: Added HTTP 'Host' header character validation to prevent
cache poisoning attacks when base_url auto-detection is used.

Security: Added FSCommand and seekSegmentTime to the 'evil attributes'
list in CI_Security::xss_clean().

See also :

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=203401
https://codeigniter.com/userguide2/changelog.html
http://www.nessus.org/u?72512bde

Solution :

Update the affected package.

Risk factor :

High

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 86180 ()

Bugtraq ID:

CVE ID:

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now