RHEL 5 / 6 : flash-plugin (RHSA-2015:1814)

This script is Copyright (C) 2015-2017 Tenable Network Security, Inc.


Synopsis :

The remote Red Hat host is missing a security update.

Description :

An updated Adobe Flash Player package that fixes multiple security
issues is now available for Red Hat Enterprise Linux 5 and 6
Supplementary.

Red Hat Product Security has rated this update as having Critical
security impact. Common Vulnerability Scoring System (CVSS) base
scores, which give detailed severity ratings, are available for each
vulnerability from the CVE links in the References section.

The flash-plugin package contains a Mozilla Firefox compatible Adobe
Flash Player web browser plug-in.

This update fixes multiple vulnerabilities in Adobe Flash Player.
These vulnerabilities, detailed in the Adobe Security Bulletin
APSB15-23 listed in the References section, could allow an attacker to
create a specially crafted SWF file that would cause flash-plugin to
crash, execute arbitrary code, or disclose sensitive information when
the victim loaded a page containing the malicious SWF content.
(CVE-2015-5567, CVE-2015-5568, CVE-2015-5570, CVE-2015-5571,
CVE-2015-5572, CVE-2015-5573, CVE-2015-5574, CVE-2015-5575,
CVE-2015-5576, CVE-2015-5577, CVE-2015-5578, CVE-2015-5579,
CVE-2015-5580, CVE-2015-5581, CVE-2015-5582, CVE-2015-5584,
CVE-2015-5587, CVE-2015-5588, CVE-2015-6676, CVE-2015-6677,
CVE-2015-6678, CVE-2015-6679, CVE-2015-6682)

All users of Adobe Flash Player should install this updated package,
which upgrades Flash Player to version 11.2.202.521.

See also :

https://www.redhat.com/security/data/cve/CVE-2015-5567.html
https://www.redhat.com/security/data/cve/CVE-2015-5568.html
https://www.redhat.com/security/data/cve/CVE-2015-5570.html
https://www.redhat.com/security/data/cve/CVE-2015-5571.html
https://www.redhat.com/security/data/cve/CVE-2015-5572.html
https://www.redhat.com/security/data/cve/CVE-2015-5573.html
https://www.redhat.com/security/data/cve/CVE-2015-5574.html
https://www.redhat.com/security/data/cve/CVE-2015-5575.html
https://www.redhat.com/security/data/cve/CVE-2015-5576.html
https://www.redhat.com/security/data/cve/CVE-2015-5577.html
https://www.redhat.com/security/data/cve/CVE-2015-5578.html
https://www.redhat.com/security/data/cve/CVE-2015-5579.html
https://www.redhat.com/security/data/cve/CVE-2015-5580.html
https://www.redhat.com/security/data/cve/CVE-2015-5581.html
https://www.redhat.com/security/data/cve/CVE-2015-5582.html
https://www.redhat.com/security/data/cve/CVE-2015-5584.html
https://www.redhat.com/security/data/cve/CVE-2015-5587.html
https://www.redhat.com/security/data/cve/CVE-2015-5588.html
https://www.redhat.com/security/data/cve/CVE-2015-6676.html
https://www.redhat.com/security/data/cve/CVE-2015-6677.html
https://www.redhat.com/security/data/cve/CVE-2015-6678.html
https://www.redhat.com/security/data/cve/CVE-2015-6679.html
https://www.redhat.com/security/data/cve/CVE-2015-6682.html
https://helpx.adobe.com/security/products/flash-player/apsb15-23.html
http://rhn.redhat.com/errata/RHSA-2015-1814.html

Solution :

Update the affected flash-plugin package.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.3
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true