FreeBSD : openslp -- denial of service vulnerability (3c259621-5d4a-11e5-9ad8-14dae9d210b8)

This script is Copyright (C) 2015-2017 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing a security-related update.

Description :

Qinghao Tang reports :

The function ParseExtension() in openslp 1.2.1 contains vulnerability:
an attacker can cause a denial of service (infinite loop) via a packet
with crafted 'nextoffset' value and 'extid' value.

See also :

http://seclists.org/oss-sec/2015/q3/559
http://www.nessus.org/u?18375ccc

Solution :

Update the affected package.

Risk factor :

High

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 85991 ()

Bugtraq ID:

CVE ID: CVE-2015-5155

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now