openSUSE Security Update : libvdpau (openSUSE-2015-576)

This script is Copyright (C) 2015 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

libvdpau was updated to use secure_getenv() instead of getenv() for
several variables so it can be more safely used in setuid
applications.

- CVE-2015-5198: libvdpau: incorrect check for security
transition (bnc#943967)

- CVE-2015-5199: libvdpau: directory traversal in dlopen
(bnc#943968)

- CVE-2015-5200: libvdpau: vulnerability in trace
functionality (bnc#943969)

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=943967
https://bugzilla.opensuse.org/show_bug.cgi?id=943968
https://bugzilla.opensuse.org/show_bug.cgi?id=943969

Solution :

Update the affected libvdpau packages.

Risk factor :

High / CVSS Base Score : 7.2
(CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C)

Family: SuSE Local Security Checks

Nessus Plugin ID: 85926 ()

Bugtraq ID:

CVE ID: CVE-2015-5198
CVE-2015-5199
CVE-2015-5200

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now