Adobe Shockwave Player <= 12.1.9.160 Multiple RCE (APSB15-22) (Mac OS X)

This script is Copyright (C) 2015 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host contains a web browser plugin that is
affected by multiple remote code execution vulnerabilities.

Description :

The remote Mac OS X host contains a version of Adobe Shockwave Player
that is prior or equal to 12.1.9.160. It is, therefore, affected by
multiple remote code execution vulnerabilities due improper validation
of user-supplied input. A remote attacker can exploit these
vulnerabilities to corrupt memory, potentially resulting in the
execution of arbitrary code.

See also :

https://helpx.adobe.com/security/products/shockwave/apsb15-22.html

Solution :

Upgrade to Adobe Shockwave Player 12.2.0.162 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: MacOS X Local Security Checks

Nessus Plugin ID: 85881 ()

Bugtraq ID: 76664

CVE ID: CVE-2015-6680
CVE-2015-6681

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now