GLSA-201508-03 : Icecast: Denial of Service

This script is Copyright (C) 2015 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-201508-03
(Icecast: Denial of Service)

When stream_auth handler is defined for URL authentication and a request
is sent without login credentials, a Denial of Service condition can
occur.

Impact :

A remote attacker could possibly cause a Denial of Service condition.

Workaround :

Users of affected versions can change stream_auth mountpoints to use
password authentication instead.

See also :

https://security.gentoo.org/glsa/201508-03

Solution :

All icecast users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-misc/icecast-2.4.2'

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 85431 ()

Bugtraq ID:

CVE ID: CVE-2015-3026

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now