MS15-087: Vulnerability in UDDI Services Could Allow Elevation of Privilege (3082459)

This script is Copyright (C) 2015-2017 Tenable Network Security, Inc.


Synopsis :

The remote Windows host is affected by an elevation of privilege
vulnerability.

Description :

The remote Windows host is affected by an elevation of privilege
vulnerability in the Universal Description, Discovery, and Integration
(UDDI) Services component due to improper validation and sanitization
of user-supplied input to the 'searchID' parameter of the 'explorer'
frame in frames.aspx. A remote attacker can exploit this vulnerability
by submitting a specially crafted URL to a target site, resulting in
the execution of arbitrary script code in the context of the current
user.

Note: During testing it was discovered that BizTalk configurations
running on Windows versions not specified in the bulletin were also
impacted. Therefore, this plugin checks the vulnerability state of the
cross-site scripting flaw and not the specific OS variant.

See also :

https://technet.microsoft.com/library/security/MS15-087

Solution :

Microsoft has released a set of patches for UDDI Services including
patches for Microsoft Windows 2008 SP2, BizTalk Server 2010, 2013, and
2013 R2.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 3.6
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Windows : Microsoft Bulletins

Nessus Plugin ID: 85406 ()

Bugtraq ID: 76259

CVE ID: CVE-2015-2475

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now