MS15-090: Vulnerabilities in Microsoft Windows Could Allow Elevation of Privilege (3060716)

This script is Copyright (C) 2015-2017 Tenable Network Security, Inc.


Synopsis :

The remote Windows host is affected by multiple elevation of privilege
vulnerabilities.

Description :

The remote Windows host is affected by multiple elevation of privilege
vulnerabilities in Windows Object Manager :

- A flaw exists in Windows Object Manager due to a failure
to properly validate and enforce impersonation levels. A
remote, authenticated attacker can exploit this
vulnerability, via a specially crafted application, to
bypass impersonation-level security, resulting in a
privilege escalation. (CVE-2015-2428)

- A flaw exists in Windows Object Manager due to a failure
to properly restrict certain registry interactions from
within vulnerable sandboxed applications. A remote
attacker can exploit this vulnerability by convincing a
user to open specially crafted file that invokes a
vulnerable sandboxed application, to interact with the
registry and escape the application sandbox, resulting
in a privilege escalation. (CVE-2015-2429)

- A flaw exists in Windows Object Manager due to a failure
to properly restrict certain filesystem interactions
from within vulnerable sandboxed applications. A remote
attacker can exploit this vulnerability by convincing a
user to open a specially crafted file that invokes a
vulnerable sandboxed application, to interact with the
filesystem and escape the application sandbox, resulting
in a privilege escalation. (CVE-2015-2430)

See also :

https://technet.microsoft.com/en-us/library/security/MS15-090

Solution :

Microsoft has released a set of patches for Windows Vista, 2008, 7,
2008 R2, 8, RT, 2012, 8.1, RT 8.1, and 2012 R2.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.0
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows : Microsoft Bulletins

Nessus Plugin ID: 85322 ()

Bugtraq ID: 76227
76231
76233

CVE ID: CVE-2015-2428
CVE-2015-2429
CVE-2015-2430

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now