Cisco AnyConnect Secure Mobility Client < 3.1.8009.0 / 4.0.x < 4.0.2052.0 / 4.1.x < 4.1.28.0 Multiple Vulnerabilities

This script is Copyright (C) 2015-2017 Tenable Network Security, Inc.


Synopsis :

The remote host is affected by multiple vulnerabilities.

Description :

The Cisco AnyConnect Secure Mobility Client installed on the remote
host is a version prior to 3.1.8009.0, or is version 4.0.x prior to
4.0.2052.0, or version 4.1.x prior to 4.1.28.0. It is, therefore,
affected by the following vulnerabilities :

- A flaw exists due to not sanitizing the input of IPC
commands. A local attacker, using a specially crafted
IPC command, can exploit this to write to arbitrary user
space memory and execute code with escalated privileges.
(CVE-2015-0664)

- A path traversal flaw exists due to the Hostscan module
not properly sanitizing user input in certain IPC
commands. A local, authenticated attacker, using a
specially crafted IPC command, can exploit this to
traverse outside restricted paths and write or overwrite
arbitrary files. (CVE-2015-0665)

See also :

https://tools.cisco.com/security/center/viewAlert.x?alertId=37861
https://tools.cisco.com/security/center/viewAlert.x?alertId=37862

Solution :

Upgrade to Cisco AnyConnect Secure Mobility Client version
3.1.8009.0 / 4.0.2052.0 / 4.1.28.0 or later

Risk factor :

Medium / CVSS Base Score : 6.6
(CVSS2#AV:L/AC:L/Au:N/C:N/I:C/A:C)
CVSS Temporal Score : 6.6
(CVSS2#E:ND/RL:U/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 85266 ()

Bugtraq ID: 73120

CVE ID: CVE-2015-0664
CVE-2015-0665

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now