HP System Management Homepage < 7.2.5 / 7.4.1 Multiple Vulnerabilities (POODLE)

This script is Copyright (C) 2015-2016 Tenable Network Security, Inc.


Synopsis :

The remote web server is affected by multiple vulnerabilities.

Description :

According to the web server's banner, the version of HP System
Management Homepage (SMH) hosted on the remote web server is prior to
7.2.5 or 7.4.1. It is, therefore, affected by the following
vulnerabilities :

- An information disclosure vulnerability exists exists in
OpenSSL due to the pretty printing functions leaking
information from the stack. A remote attacker can
exploit this to disclose sensitive information that is
echoed from pretty printing output. (CVE-2014-3508)

- A race condition exists in OpenSSL that is triggered
when handling Elliptic Curve (EC) Point Format Extension
data in a resumed session. A remote attacker can exploit
this to corrupt memory, resulting in a denial of service
condition or the execution of arbitrary code.
(CVE-2014-3509)

- A flaw exists in OpenSSL related to handling fragmented
'ClientHello' messages that allows a man-in-the-middle
attacker to force usage of TLS 1.0 regardless of higher
protocol levels being supported by both the server and
the client. (CVE-2014-3511)

- A denial of service vulnerability exists in OpenSSL in
the DTLS SRTP extension parsing code due to improper
handling of handshake messages. A remote attacker can
exploit this, via a specially crafted handshake message,
to cause a memory leak, resulting in a denial of
service. (CVE-2014-3513)

- A man-in-the-middle (MitM) information disclosure
vulnerability, known as POODLE, exists due to the way
SSL 3.0 handles padding bytes when decrypting messages
encrypted using block ciphers in cipher block chaining
(CBC) mode. A MitM attacker can decrypt a selected byte
of a cipher text in as few as 256 tries if they are able
to force a victim application to repeatedly send the
same data over newly created SSL 3.0 connections.
(CVE-2014-3566)

- A denial of service vulnerability exists in OpenSSL due
to a failure to properly verify the integrity of session
tickets. A remote attacker can exploit this, via a large
number of invalid session tickets, to cause a memory
leak, resulting in a denial of service condition.
(CVE-2014-3567)

- An error exists in OpenSSL related to the build
configuration process and the 'no-ssl3' build option
that allows servers and clients to process insecure SSL
3.0 handshake messages. (CVE-2014-3568)

- A NULL pointer dereference flaw exists in OpenSSL that
is triggered when an SRP ciphersuite is specified
without being properly negotiated with the client. A
remote attacker controlling a malicious server can
exploit this to crash an OpenSSL client. (CVE-2014-3569)

- A remote code execution vulnerability exists due to a
buffer overflow condition in the Single Sign On (SSO)
module. A remote attacker, using a long parameter, can
exploit this to execute arbitrary code in the context of
SYSTEM. (CVE-2015-2133)

Note that these vulnerabilities only affect instances of SMH running
on Windows and Linux hosts.

See also :

http://www.nessus.org/u?15dd8325
http://www.nessus.org/u?9a5380ec
http://www.zerodayinitiative.com/advisories/ZDI-15-262/
https://www.imperialviolet.org/2014/10/14/poodle.html
https://www.openssl.org/~bodo/ssl-poodle.pdf
https://tools.ietf.org/html/draft-ietf-tls-downgrade-scsv-00

Solution :

Upgrade to HP System Management Homepage (SMH) 7.2.5 / 7.4.1 or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.4
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now