openSUSE Security Update : libidn (openSUSE-2015-497)

This script is Copyright (C) 2015 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

libidn was updated to version 1.31 to fix one security issue.

This security issue was fixed :

- CVE-2015-2059: Out-of-bounds read with stringprep on
invalid UTF-8 (bsc#923241).

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=923241

Solution :

Update the affected libidn packages.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 84866 ()

Bugtraq ID:

CVE ID: CVE-2015-2059

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now