FreeBSD : moodle -- multiple vulnerabilities (43891162-2d5e-11e5-a4a5-002590263bf5)

This script is Copyright (C) 2015-2016 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing one or more security-related
updates.

Description :

Marina Glancy reports :

MSA-15-0026: Possible phishing when redirecting to external site using
referer header. (CVE-2015-3272)

MSA-15-0027: Capability 'mod/forum:canposttomygroups' is not respected
when using 'Post a copy to all groups' in forum (CVE-2015-3273)

MSA-15-0028: Possible XSS through custom text profile fields in Web
Services (CVE-2015-3274)

MSA-15-0029: JavaScript injection in SCORM module (CVE-2015-3275)

See also :

http://seclists.org/oss-sec/2015/q3/94
https://docs.moodle.org/dev/Moodle_2.7.9_release_notes
https://docs.moodle.org/dev/Moodle_2.8.7_release_notes
https://docs.moodle.org/dev/Moodle_2.9.1_release_notes
http://www.nessus.org/u?1b5dee57

Solution :

Update the affected packages.

Risk factor :

Medium / CVSS Base Score : 5.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N)

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 84861 ()

Bugtraq ID:

CVE ID: CVE-2015-3272
CVE-2015-3273
CVE-2015-3274
CVE-2015-3275

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now