Adobe Shockwave Player <= 12.1.8.158 Multiple RCE Vulnerabilities (APSB15-17) (Mac OS X)

This script is Copyright (C) 2015-2016 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host contains a web browser plugin that is
affected by multiple remote code execution vulnerabilities.

Description :

The remote Mac OS X host contains a version of Adobe Shockwave Player
that is prior to or equal to 12.1.8.158. It is, therefore, affected by
multiple remote code execution vulnerabilities :

- An unspecified memory corruption issue exists due to
improper validation of user-supplied input. An attacker
can exploit this to cause a denial of service condition
or the execution of arbitrary code. (CVE-2015-5120)

- An unspecified memory corruption issue exists due to
improper validation of user-supplied input. An attacker
can exploit this to cause a denial of service condition
or the execution of arbitrary code. (CVE-2015-5121)

See also :

https://helpx.adobe.com/security/products/shockwave/apsb15-17.html

Solution :

Upgrade to Adobe Shockwave Player 12.1.9.159 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: MacOS X Local Security Checks

Nessus Plugin ID: 84764 ()

Bugtraq ID: 75736
75736

CVE ID: CVE-2015-5120
CVE-2015-5121

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now