openSUSE Security Update : cups-filters (openSUSE-2015-492)

This script is Copyright (C) 2015 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

cups-filters was updated to fix three security issues.

These security issues were fixed :

- CVE-2015-2265: The remove_bad_chars function in
utils/cups-browsed.c in cups-filters before 1.0.66
allowed remote IPP printers to execute arbitrary
commands via consecutive shell metacharacters in the (1)
model or (2) PDL. NOTE: this vulnerability exists
because of an incomplete fix for CVE-2014-2707
(bsc#921753).

- CVE-2015-3279: Texttopdf integer overflow (incomplete
fix for CVE-2015-3258) (bsc#937018).

- CVE-2015-3258: Texttopdf heap-based buffer overflow
(bsc#936281).

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=921753
https://bugzilla.opensuse.org/show_bug.cgi?id=936281
https://bugzilla.opensuse.org/show_bug.cgi?id=937018

Solution :

Update the affected cups-filters packages.

Risk factor :

High / CVSS Base Score : 8.3
(CVSS2#AV:A/AC:L/Au:N/C:C/I:C/A:C)

Family: SuSE Local Security Checks

Nessus Plugin ID: 84756 ()

Bugtraq ID:

CVE ID: CVE-2014-2707
CVE-2015-2265
CVE-2015-3258
CVE-2015-3279

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now